티스토리 뷰

환경 

- gradle-5.2.1

- spring boot 2.1.3.release

- jdk 1.8 

- eclipse 


Gradle 빌드시 Lombok으로 처리하던 getter, setter, log 쪽이 모두 컴파일 오류가 납니다. 

구글 검색을 해보고 annotationProcessor, compileOnly 설정으로 해결했습니다.


1
2
3
4
5
6
7
    dependencies {
        annotationProcessor("org.projectlombok:lombok:${lombokVersion}")
        compileOnly("org.projectlombok:lombok:${lombokVersion}")
        implementation 'org.springframework.boot:spring-boot-starter-web'
        ...
        ...
    }
cs


혹 이런 이슈 발생하신다면 참고하세요. 


1
2
3
4
    compileOnly("org.projectlombok:lombok:${lombokVersion}")
    testCompileOnly("org.projectlombok:lombok:${lombokVersion}")
    annotationProcessor("org.projectlombok:lombok:${lombokVersion}")
    testAnnotationProcessor("org.projectlombok:lombok:${lombokVersion}")
cs


댓글
댓글쓰기 폼