티스토리 뷰

UI(Front-End)

웹 호환모드 설정

까오기 까오기 2019. 6. 19. 10:37

현재 제공 하는 서비스는 IE 11 이상, 크롬에서 정상 작동을 합니다. 

그런데 IE 11을 사용해도 문서 모드가 8, 9 버전으로 되어 있는 경우가 있습니다. 

이런 경우 설정에서 'F12개발자 도구'를 선택하고 문서모드에서 버전을 설정해줘야 합니다. 

서비스 하는 애플리케이션에서는 호환성 모드를 설정해 주는 게 좋습니다. 

 

IE 호환모드  설정

Here are your options:

  • "IE=edge"
  • "IE=11"
  • "IE=EmulateIE11"
  • "IE=10"
  • "IE=EmulateIE10"
  • "IE=9"
  • "IE=EmulateIE9
  • "IE=8"
  • "IE=EmulateIE8"
  • "IE=7"
  • "IE=EmulateIE7"
  • "IE=5"

엣지 및 크롬브라우저 설정

<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1">

참고 

https://stackoverflow.com/questions/6771258/what-does-meta-http-equiv-x-ua-compatible-content-ie-edge-do

댓글
댓글쓰기 폼